Page 1 of 2

Fonts stop to work (after Windows 10 Creators Update)

PostPosted: Tue Apr 18, 2017 7:44 am
by Bluesman
Hi... was very excited yesterday when installed "FE". Worked perfect. But today when started pc and shall work with webproject, some of the fonts doesn't work. Was ok yesterday?? I open "FE" and can see that this fonts are marked green (installed and active) but they are not displaying (previewing). In this group I have about 50 fonts and all is working except for this 4 fonts. I try to activate them with another fonthandler and that works good. So I don't think there is a problem with the fonts.

I noticed that the Truetype fonts TTF that are placed together with other webfonts in my Webfonts library shows as Opentype fonts OTF in "FE" why? And when browsing the fonts in the library I can see that there are dublicates of some OTF fonts, some are with a greenish otf marque and some with a redish otf symbol??


Re: Fonts stop to work

PostPosted: Tue Apr 18, 2017 8:48 am
by Bluesman
Here's a screenshot... wondering if there can be a conflict??

Re: Fonts stop to work - How search for conflict?

PostPosted: Tue Apr 18, 2017 6:29 pm
by Bluesman
Hi again... Well seams like I solved the problem. Was some corrupted font files to erase and I cleaned up in the webfonts folders. Had both otf and ttf files in some of them. Removed the otf so I didn't choose the wrong ones. Since both otf and ttf had the same symbol ??
But everything works now.

Re: Fonts stop to work

PostPosted: Thu Apr 20, 2017 12:56 am
by admin
Please send me the problem fonts (support (at) proximasoftware (dot) com), I'll try to test them and find out why the preview is empty image.
FontExpert uses some defined symbols in a font to generate preview. So if it can not find symbols, the thumbnail appears like a white
space. But it seems the font is working. If FontExpert can not load font, it writes an error message text on white space.

Re: Fonts stop to work

PostPosted: Thu Apr 20, 2017 6:55 am
by Bluesman
Hi again. Thanks for answer and suggestion. I think I solved the problem by make a more clean link structure in the "Groups" When having the problem I did some linking between the "Groups" because some different groups had almost the same fonts. Was easier... I saw this in a Youtube video tutorial for "FE"... but after starting over and just link to the different groups from the Library it works great again and I have a more clean link structure...
Thanks for a great software.

Re: Fonts stop to work

PostPosted: Sat May 20, 2017 12:36 am
by admin
We have received similar reports from users who installed Windows system updates. More likely the issue appears after installing Windows 10 Creators Update. (Although this information is preliminary. On user thinks the problem appeared after installing Net Framework update.)

The issue appears after turning computer off and starting again. It seems that reported fonts are not loaded correctly on Windows startup. This is the reason why these fonts do not work in Adobe's and other software and are displayed in FontExpert as white area. Users has reported that the fonts that appear not working from time to time are random. (So the problem is not in the fonts.)
The permanently installed fonts are listed in registry key: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts" and all font managing programs are working with this registry key.

We are investigating the issue, but we are sure FontExpert is not responsible for it, as the list of permanently installed fonts is a shared system resource and Windows is responsible for loading all fonts on startup.

We are not thinking that Microsoft is perfect and adding problems with new Windows update is something unusual.
For example, Microsoft introduced the issue with Type 1 fonts in Windows Vista (fonts were not loaded on Windows startup) and we had to develop a special utility to fix Microsoft's bug.

Re: Fonts stop to work (after Windows 10 Creators Update)

PostPosted: Sun May 21, 2017 3:15 am
by admin
If you have Windows 10, delete the Type1Loader registry entry which is installed by FontExpertSetup.
Two users has sent a preliminary report that deleting Type1Loader helped to solve the issue discussed in this topic.
Type1Loader utility affects only Type 1 fonts, and it is not needed in Windows 10 (as Microsoft has fixed an issue in Windows Vista and Windows 7 with loading Type 1 fonts on Windows startup).

If you have Windows 10:
1) Run regedit.exe
2) Go to registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
3) Delete entry:
FontExpertType1Loader=C:\Program Files\FontExpert\Type1Loader.exe

or just delete file:
C:\Program Files\FontExpert\Type1Loader.exe

This utility is not needed in Windows 10 in any case, and we will update setup in the following release.
(In Windows 10, FontExpertSetup of current version 14 release 1 installs this utility.)

But we are not 100% sure that removingType1Loader is the solution of the problem in Windows 10 discussed in this topic, and at this moment we are waiting for reports from our users.

Note from Admin: Later the issue has occurred on our test computer. See my reply below, from May 27, 2017.

Re: Fonts stop to work (after Windows 10 Creators Update)

PostPosted: Sun May 21, 2017 5:12 pm
by Bluesman
2 days and works great :P

Re: Fonts stop to work (after Windows 10 Creators Update)

PostPosted: Mon May 22, 2017 2:51 am
by Gonzha
At first it helped, but then everything came back
I Solved the problem radically - rolled back Windows before the previous update

If your working time and nerves are dear to you :-) - then I recommend doing the same ... until the right solution is found the developers

P.S. Sorry for my English

Re: Fonts stop to work (after Windows 10 Creators Update)

PostPosted: Mon May 22, 2017 7:04 am
by Bluesman
Hi Gonzha, you make me nervous... Now 3 days for me and works perfect with loading the fonts. I have the latest updates (creators update) and all security patches until today. About 66.000 fonts indexed in library and about 350 (including) syst fonts that are loaded at start.

Re: Fonts stop to work (after Windows 10 Creators Update)

PostPosted: Mon May 22, 2017 5:57 pm
by admin
The computer (after installing Windows Update):

Edition: Windows 10 Pro
Version: 1703
OS Build: 15063.296
FontExpert 2016 version 14.0 Release 1 x64
Type1Loader entry is present (Type1Loader runs on startup)
Total ~300 fonts permanently installed:
~180 fonts are installed in Fonts folder (the system fonts that are part of Windows 10)
~120 fonts are installed in Groups (in Library, thus, outside Fonts folder).

a) after installing Windows Update - all fonts are OK (no "white boxes")
b) then after "Shut down", Turn computer on - all fonts are OK
c) then after "Restart" - all fonts are OK

Re: Fonts stop to work (after Windows 10 Creators Update)

PostPosted: Tue May 23, 2017 4:02 pm
by Bluesman
Whell.... now back to the beginning. But worse. After restarting almost all fonts stop to work. Some days of happiness....
But now :x
Did a restart of the pc, but didn't solve the problem. I disactivated all fonts in FontExpert. Restarted the pc, activated the fonts. Now works.
Solution: Never turn off the pc :roll:

Re: Fonts stop to work (after Windows 10 Creators Update)

PostPosted: Wed May 24, 2017 11:01 am
by Bluesman
I have done some testing... When I turn on the pc and let it startup complete without using it. When ready I start using and check FontExpert and the softwares I use. Works good. Has done this several times and works all the time. If I don't wait for the pc to start up complete... it get's instabil...sometimes works and sometimes not ?? So looks there is a interference with some other startupprocess or the order which it starts up.

I experienced this problem with "Nexus Font" which worked perfect in all OS before "10".

Before Nexus Font I used "Adobe Type Manager". Never a problem. Do you know if they have this issue? It's good with a little industrial spionage...

by Bluesman ยป 24 May 2017 05:15 pm:

Well... had to drop this temporary solution to :!: Failed at one upstart... so the problem continuous as earlier. Was checking the web for windows 10 Creators font problem... there are a lot. So I assume Windows has done changes with the font handling???

Interesting link... we're not alone: ... n-etc.html

Re: Fonts stop to work (after Windows 10 Creators Update)

PostPosted: Sat May 27, 2017 10:04 am
by admin
It seems Microsoft has introduced a serious bug with font handling in their new "update". There are many complaints in Internet describing unexpected issues with fonts.

Today the issue we discussing in this topic has occurred on our test computer with Windows 10 + Creators Update:
Edition: Windows 10 Pro
Version: 1703
OS Build: 15063.296

We see the "white" preview for many fonts in the Wordpad font list and in FontExpert.
The "white" fonts are present in Windows memory, but having incorrect preview (just not working).
Some "white" fonts are located in Windows Fonts folder, some are outside Fonts folder. Some fonts are OpenType/CFF, some are OpenType/TrueType, some fonts are TrueType.
At the same time there are OpenType and TrueType fonts that are loaded and previewed correctly and are located in Fonts folder or also working but are located outside Fonts folder.
There is no consistent pattern on the reason why some fonts are working and some fonts are not.


How to make "white" fonts working (manually):

If you started computer and found that some fonts are not working (like on the image above in Wordpad menu):
1) Go to FontExpert (or use other software if you are not a user of FontExpert)
2) Select the fonts that are previewed as "white" samples
3) Uninstall them
4) Install them
5) Exit FontExpert, run it again (this step is optional, but needed to make FontExpert to create new preview of the fonts in internal cache)

But be ready that the issue may occur again on the next Windows session (after shutdown).
(We have not found better solution yet.)

We think this is a bug of Microsoft included in the latest Windows Update (called "Creators Update").
The issue occurs in Windows 10, Version 1703, OS Build 15063.296.

The solution: FontsReloader

Please try the following utility, called FontsReloader.

If you see "white fonts", run this utility once (manually, double click it).

How to start FontsReloader on each Windows start up:
1) Copy FontsReloader_x64.exe to "C:\Program Files\FontExpert\"
2) Double click FontsReloader_x64_add_to_Run.reg file and confirm adding information to Registry.
Please reply, have it helped to fix the issue on your computer.

Re: Fonts stop to work (after Windows 10 Creators Update)

PostPosted: Mon May 29, 2017 7:06 am
by Bluesman
Am a little unsecure how to achieve this... aspecially with the reg file?? After doing this... willl it work all the time? Does it affect some performance?