Page 1 of 1

FE doesn't locate Full Font Name in DB Search

PostPosted: Tue Jul 29, 2014 9:30 am
by Monkeylogic
I’m finding that when I load a file in Illustrator or Photoshop which is missing fonts, I open FontExpert to install the missing fonts. However, Illustrator and Photoshop use the full font name and when I attempt to conduct a DB Search for these names in FontExpert, I usually get no results. When this occurs I have to reduce the words used in the search to locate all the variations of the font family, activate all of them, and then I’m able to figure out which font is the one I need.

To test this out this font search problem I located a few fonts in my library where the Font Name and the Font Full Name are different. In this case I selected Zurich Extra Black BT and the Full Name for it is Zurich XBlk BT Extra Black. If I enter the full name into the DB Search, I get no search results. If I enter the Full Name, the font is found.

I installed the trial version of 2014 on another computer to see if the problem was regulated to my main computer but it was unable to locate the font as well.

Re: FE doesn't locate Full Font Name in DB Search

PostPosted: Sat Sep 20, 2014 11:41 am
by admin
Missing Fonts Loader for InDesign when searches for a missing font tries to match it by PostScript font name, then by full name, then by font name. PostScript name string is better to identify a font than Full Name. TrueType/OpenType fonts include Full Name name string assigned by designer which in many cases omit "Regular", and can differ from the full name synthesized from "Family Name" + "Subfamily Name". So there are "two full names" - one is a name string ("Full Name" in FontExpert Properties window), and the other is a full name as a combination of the name strings: "Family Name" + "Subfamily Name".