No activation of Postscript fonts at Win startup [not a bug]

A place to discuss any issues found in FontExpert, steps to reproduce, workaround or how to fix

No activation of Postscript fonts at Win startup [not a bug]

Postby MacQ » Tue Nov 15, 2005 10:48 am

Hello.

I've been trying FontExpert now for a while (version 6) and when I install Postscript fonts and restart the computer the fonts are no longer activated. None of the Windows programs finds them and FontExpert doesn't show them in windows fonts either.
When I go to groups tab the fonts are bold (i.e. installed) and when i try to install them again FE says that this fonts are already installed.

Help please.
MacQ
 

Postby support » Fri Nov 18, 2005 11:37 am

"Fonts are already installed" means that paths to your fonts are listed in registry. (There is special registry key where postscript fonts are listed.)

So the question is: why Windows doesnt load these fonts on start up?
Please give us more information about your system (you can contact our technical support via support form):
1. Windows version (e.g. Windows XP)
2. Service Pack # (e.g. SP 2)
3. Any other details about your fonts, and where fonts are located.

(In the case fonts are located on some non-Windows logical drive,
make sure Windows "knows" about this logical drive on start up.)

In the case you feel that fonts are non-standard or suspicious,
you also can send one font as a sample to our technical support via e-mail (support@).
support
 
Posts: 64
Joined: Thu Feb 10, 2005 12:32 pm
Location: Proxima Software

Postby MacQ » Fri Nov 18, 2005 12:50 pm

I've had Adobe Type Manager installed before and uninstalled it.
I've also tried out the Extensis Suitcase trial and the fonts weren't installed (activated) on startup either.

I think i messed something up.

Anyway, I use Win XP, SP 2, and the fonts are located in a FontGroups subfolder. They're on the HDD.

The fonts are alright, because I used them before and they work. And they did install before. I think that ATM has something to do with it.

Will look into it.
MacQ
 

Postby MacQ » Fri Nov 18, 2005 5:30 pm

Well, I installed ATM back again and guess what - it works.

I thought WinXP had support for PostScript fonts.

Guess not.
MacQ
 

Postby support » Sat Nov 19, 2005 9:20 am

Windows XP with SP2 (without ATM) doesn't have this problem. Probably ATM is not a key to solution, although it's installation has helped somehow in your case.
Some additional information is needed, for example, the list and locations of postscript fonts on your computer.
If you still need to find a reason of the problem,
please run regedit.exe and export the following registry key (save it to .reg file):
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Type 1 Installer\Type 1 Fonts
and please send this file to our technical support (support@) as attachment. I hope it can give some information.
support
 
Posts: 64
Joined: Thu Feb 10, 2005 12:32 pm
Location: Proxima Software

Postby MacQ » Sat Nov 19, 2005 12:21 pm

It's no problem. I probably did something (like cleaned the registry with a registry cleaner :oops: ) and messed something up.

The key is as follows:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Type 1 Installer\Type 1 Fonts]

It's empty.
MacQ
 

Postby support » Sat Nov 19, 2005 2:28 pm

It's a key where Windows XP keeps a list of installed PostScript fonts. No fonts are installed in this case (in other words, Windows XP doesn't see any installed PostScript fonts).
You can just install several .PFM & .PFB fonts using FontExpert or using Control Panel / Fonts window. New font records must appear in this registry key.
support
 
Posts: 64
Joined: Thu Feb 10, 2005 12:32 pm
Location: Proxima Software

Postby Guest » Sun Nov 20, 2005 2:17 pm

Now that I've installed ATM it works. The font faces are in the registry.

I'm happy now. Thanks for the help.
Guest
 

ATM vs. Font Expert

Postby Susan Taylor » Wed Mar 08, 2006 3:26 pm

I have ATM Deluxe installed. Font Expert was highly recommended in a CorelDraw forum.

As I understand it, only one font manager is allowed at at time. How do I try out Font Expert without uninstalling (it won't Turn Off) ATM and losing my activation/deactivation settings for different fonts.

Any way to import ATM font groups into Font Expert?

Thanks.
Susan Taylor
 

Postby admin » Wed Mar 08, 2006 3:44 pm

Font managers are NOT mutually exclusive. You can just install FontExpert trial version and it will co-exist with other font managers and with ATM.

But of course, you can use any font manager to install, uninstall fonts, move and delete font files. In this case it is possible to make changes that will be visible in other font managers.

Current FontExpert 2005 version 7.0 can not import groups (sets) defined in ATM. But in the case your sets are located in separate folders, it is easy to create new groups in FontExpert and include fonts located in these folders.
admin
Site Admin
 
Posts: 262
Joined: Thu Feb 10, 2005 10:20 am
Location: Proxima Software

FontExpert & font locations...

Postby Susan Taylor » Thu Mar 09, 2006 10:06 am

ATM puts all fonts in PSFonts\PFB,PFM. That's OK with me because I often installl fonts from CDs or reorganize the fonts I download. If all installed (active or not) fonts are in one place, I know that I won't inadvertently move them.

Will FontExpert copy fonts I install to PSFonts, say, if I ask it to? I presume that I can group fonts from one folder in different sets...right?

Thanks, for your help.
Susan Taylor
 

Postby admin » Thu Mar 09, 2006 8:41 pm

In FontExpert you can create new group and when you are adding fonts to new group you have an option, how to add fonts. One option is Copy fonts (from original folder to group folder), another option is Link fonts (in this case you put shortcuts to group folder, while original files are still located in original folder). (The third option is Move font files.)

In the case you want to keep PostScript fonts in PSFONTS\PFM folder, use the Link option when you are adding those fonts to a FontExpert group.
admin
Site Admin
 
Posts: 262
Joined: Thu Feb 10, 2005 10:20 am
Location: Proxima Software

Postby Susan Taylor » Fri Mar 10, 2006 9:58 am

Must ALL fonts in a group be activated/deactivated together? Or can some be activated; others, deactivated? Sometimes, I activate some, not all, typefaces of a font because I want to keep the font family together but not use all typefaces all the time.

What happens to the Shortcuts that ATM has created in Windows\Fonts for the fonts installed in PSFonts? If I Link the same fonts from PSFonts in FontExpert groups, does that add another bunch of Shortcuts.

I tried to find answers to these questions in the FontExpert Manual, but could not. Thank you for your patience. I want to make sure that the program will do what I want it to do, not what I hope it will do.

Susan
Susan Taylor
 

Postby admin » Fri Mar 10, 2006 7:02 pm

Fonts in a group can be activated/uninstalled separately (as you desire) or all together.

When you are adding fonts to a group and choose Link option, FontExpert creates it's own shortcuts to fonts and saves them to a group folder.
(Short cuts are small files that are located in a group folder.)

Sorry that FontExpert manual is not detailed. (We asways assumed that users don't like read manuals, and we tried to design the program interface as easy as possible.)
admin
Site Admin
 
Posts: 262
Joined: Thu Feb 10, 2005 10:20 am
Location: Proxima Software


Return to FontExpert Bugs, Known Issues and Workarounds

Who is online

Users browsing this forum: No registered users and 1 guest

cron