Missing Fonts Loader plug-in may stop working (InDesign)

A place to discuss any issues found in FontExpert, steps to reproduce, workaround or how to fix

Missing Fonts Loader plug-in may stop working (InDesign)

Postby admin » Sun Oct 22, 2006 5:21 am

[Message creaded by forum member: Myrna Larson]

I am using Windows XP/SP2, and FontExpert 2006 Release 1.

I really like the concept of the add-in, and it worked flawlessly for a few hours. But now I find that it is NOT loading fonts automatically (the box is checked to do that). Instead I see the InD message about missing fonts.

After opening a few more files that use inactive fonts (and the opening is unusually slow!), I get a an error message from the C run-time that reads something like "InDesign has been asked to close in an unusual manner", and then InDesign closes. If I remove the plug-in, this never happens.

I've tried deleting the plug-in from the InDesign plug-ins folder, then "reinstalling" it, but the experience is the same --
it works for a while (maybe 5 files), then stops working.
Last edited by admin on Fri Nov 10, 2006 12:09 pm, edited 2 times in total.
admin
Site Admin
 
Posts: 262
Joined: Thu Feb 10, 2005 10:20 am
Location: Proxima Software

Postby admin » Sun Oct 22, 2006 6:03 am

The description of this issue is so serious and in other words it means: "The plug-in is just not working!"

So please help us to reproduce this problem. We will investigate this issue with highest priority.

We assume you use Adobe InDesign CS2 Version 4.0 (see in InDesign Help About).

The the delay in opening indd documents (with plug-in turned on) depends on the number of fonts in the FontExpert Groups.
If you keep more than 1000 fonts in Groups it may significantly slow down opening of the InDesign document (because the plug-in searches for missing fonts in whole Groups collection in FontExpert). (We will work on this issue and opening of InDesign documents will be faster in the following release of FontExpert and plug-in.)

Please could you give us more information about configuration of fonts and Groups on your computer so we can try to reproduce this crash of InDesign?

1. Version of InDesign is: CS2 version 4.0
2. How many fonts are added to Groups?
3. How many fonts are installed permanently?

The most important for us is your typical indd file and the fonts used in it.
Please could you send some sample indd files that and the list of fonts in your Groups.

How to find out number of fonts in Groups:
a) Select topmost root folder in Groups view and choose Add to Worklist command,
b) Go to the Worklist view, number of fonts is displayed on the status bar)

Please save this Worklist to XML file (Save command) and please
send this XML file and several .INDD files (the best case - the files which leaded InD to crash) to support@proximasoftware.com address.
We guarantee privacy of your files, and all files eventually will be deleted.

We will publish the results and possible fixes or workaround here on the forum.
admin
Site Admin
 
Posts: 262
Joined: Thu Feb 10, 2005 10:20 am
Location: Proxima Software

Postby Myrna Larson » Sun Oct 22, 2006 5:50 pm

To answer your questions, I am using the most recent version of InDesign, 4.0.4. I have about 500 fonts in Font Expert Groups; when I first experienced the problems, I had about 550 fonts installed.

I am doing booklets for LP recordings that I have transferred to CD's. I have about 300 such files, and they use perhaps 150-200 fonts that I don't use in any other documents. I want to uninstall those fonts and have Font Expert (FE) activate them temporarily on-the-fly when the document is opened.

Also, when creating a new document, I want to use Font Expert's Groups to browse through my uninstalled fonts, find and temporarily activate the appropriate fonts. With new fonts, I have to do this manually, and that requires FE to be open at the same time as InD.

When I had the problems 3-4 days ago, I had InDesign open AND I had Font Expert open. I was also opening 3-8 files at once from InDesign's File/Open dialog box.

Since then, I have uninstalled more than 200 fonts. Now I have only 318 fonts permanently installed. I have more than 200 uninstalled fonts, plus copies of the installed fonts, all in a single folder. All fonts, installed and not installed, have been added to at least one FE Group using LINKS. In the case of installed fonts, the links point to the copy of the font file in my own Fonts directory rather than the copy in Windows\Fonts directory. But I have never tried to install the copy, as FE tells me the font is permanently installed.

After receiving your message, I reinstalled the add-in and again opened about 10 files in InD, one at a time. Font Expert was also open.

When doing that, I didn't have any crashes, but FE did not always install the fonts. I would open the file once and it was fine, then close the file, switch to Font Expert and uninstall the font (InD still running), open the file again and this 2nd time FE did NOT install the font and I got the message about missing fonts.

In one case, FE installed a font that was not used in the document (it HAD been used in the past, but I replaced it with a different font, so there must be some "garbage" hanging around in the InD file).

In another case I got a message about a font being missing when in fact it was not used in the document -- at least it didn't show up on InD's Find Font list.

I also saw that Font Expert had activated a font -- I was using it in the InD document -- but it didn't show as activated in the FE Files or Groups view or in the list generated from the Tools menu.

So I tried again: closed all programs down, then opened ONLY InDesign and NOT Font Expert. Working with the same files, I had no problems. In a couple of cases, I wanted to change to an uninstalled font, so I opened Font Expert, activated the font temporarily, then closed Font Expert and went back to InDesign. That sequence seemed to work OK.

BTW, opening files under these circumstances is VERY slow -- perhaps 30 seconds. If the fonts are all installed, they open almost instantaneously.

I will email you a ZIP file containing 7 or 8 files that have given problems, along with the XML list of my font groups. You will have problems with missing links in these files -- they each use a graphic file, and a haven't included them in the ZIP file.
Myrna Larson
 
Posts: 2
Joined: Sat Oct 21, 2006 1:41 pm

Postby admin » Sun Oct 22, 2006 7:41 pm

Thank you very much for description, and we have received your ZIP with sample InDesign files. We will investigate this issue and will test the plug-in with sample files. We will publish the results here.

One note and some tips on activation of missing fonts in InDesign.
As we described in the plugin manual (PDF) it is recommended to turn on the option: "[x] Use font information xml files".

We have found that plug-in will activate fonts much better when the font information XML file was created for the .INDD file.
This small XML file is created by plug-in when you save the .INDD document.

Note, that when you are opening .INDD at the first time (the file was saved earlier, when you didn't use our plug-in) XML file doesn't exist and it seems it is the reason why some fonts were not activated automatically.
(This behaviour is because of internal architecture of the plug-in and the way it communicates with Adobe InDesign, unfortunately in many cases this communication is beyond our control.)

So I would recommend you to re-save your .INDD files and make the plug-in to create small XML files (each file is actually the list of fonts used in correspondent .INDD document). After that I expect that auto-activation of missing fonts will work much better for those InDesign documents.
admin
Site Admin
 
Posts: 262
Joined: Thu Feb 10, 2005 10:20 am
Location: Proxima Software


Return to FontExpert Bugs, Known Issues and Workarounds

Who is online

Users browsing this forum: No registered users and 1 guest